Question

Enable SSO on Pega 8.2.1

Team,

For configuring SSO on Pega, I have completed the following steps, however, I am getting an error - Unable to process the SAML WebSSO request : Assertion ID is NULL.Unable to retrieve SAML response

Steps performed :-

1. Create a SAML2.0 based Authentication Service

2. Import IDP Metadata (we are using ADFS)

3. Configure Email Address as the properties passed in the Claims on the ADFS (IDP) side

Can you please guide me in this regard?

Comments

Keep up to date on this post and subscribe to comments

Pega
October 16, 2019 - 4:40am

Pega
October 18, 2019 - 10:53am

Hi Sujith,

Please share screen shots for your Authentication Service. 

You can try tracing through SAML tracer. You can also enabled below loggers, after that you will get more information in logs which will help you to debug the issue. You can check pega-rules logs after that. If you don't find the issue yourself, share the logs and SAML tracer results here with us.

Also try to re-import IDP metadata once and check.

To enable logger as mentioned in above comment you can follow below path:

Dev Studio-> Configure -> System --> Operations --> Logs --> Logging Level Setting --> Provide Logger name one by one --> Set Current Level to Debug

com.pega.pegarules.integration.engine.internal.util.PRSAMLv2Utils

com.pega.pegarules.integration.engine.internal.sso.saml.SAMLv2ResponseSSOProfileValidator

com.pega.pegarules.integration.engine.internal.sso.saml.SAMLv2ResponseProtocolValidator

Rule_Obj_Activity.pySAMLWebSSOAuthenticationActivity