Question

Email Listener is not reading and processing the emails

Hi All,

We have an email listener which is up and running but the emails are not getting picked up, read,processed by the listener.

All the configuration settings like email account receiver, Access group of service package, email listener requestor password are all correct. Due to this we are not able to trace the service email rule as well.

We have set the logging level settings as "com.pega.pegarules.integration.engine.internal.services.email.EmailListener" and got the logs for the requestor of the email listerner as below:

please help/ suggest the solution.

Regards,

Parwej

Correct Answer
July 7, 2019 - 4:22pm

Hi Mohammad,

 

From the screen-shot that you have uploaded it is showing that it is processing maximum of 1 message and then going to sleep.

Could you please check in the Email Listener that you have used for the value set for maximum number of message field.

If it is set to 1 then increase the value accordingly and then test the use case.

 

Regards,

Vikash

Comments

Keep up to date on this post and subscribe to comments

July 5, 2019 - 4:21pm

missed the log to attach in the description. attaching it here

 

Pega
July 6, 2019 - 2:43am

Hi Mohammad,

Please provide Pega rules log and mention your PRPC version.

July 7, 2019 - 10:44pm
Response to ramau

@ramau - logs are already provided in the previous comment. PRPC version is 7.1.8

July 7, 2019 - 4:22pm

Hi Mohammad,

 

From the screen-shot that you have uploaded it is showing that it is processing maximum of 1 message and then going to sleep.

Could you please check in the Email Listener that you have used for the value set for maximum number of message field.

If it is set to 1 then increase the value accordingly and then test the use case.

 

Regards,

Vikash