Question

Email channel - "Email account already used" error

Hi There,

I'm creating couple of email channels in 8.3.

The first email channel creation was a breeze. I created an email account and then I configured my new channel without problems.

When I created a second email account, I started having issues.
At the beginning the verification of my new email account failed saying that there was no email listener. I checked and I couldn't actually see any listener with the name of my second email account. So I created a new email listener using the email wizard. Now the verification works fine but when I save my new email channel I receive the error: " Email account already used"

I tried to trace while I saved but I can't see anything in the trace (not an expert in this though).

I tried to delete my second email account and recreate it but I have the same exact behaviour. I even tried to delete, reboot and recreate, same situation.

I wold really appreciate some help on this.

Cheers.

Correct Answer
October 10, 2019 - 3:07am

I tried a few times deleting and recreating email account without any luck.

After your last response I created a new email account with a new name and this time everything worked fine (Verification and Save). I guess there's something corrupted in the db, creating brand new (new name) email account overcome that situation.

We can close this thread.

 

Thanks for your help.

Comments

Keep up to date on this post and subscribe to comments

October 9, 2019 - 9:39pm

Pega
October 9, 2019 - 10:11pm

Thanks for your prompt reply.

Yes I saw a few posts on this subject:

https://community1.pega.com/community/pega-support/question/email-channel-listener  ---> My email account doesn't have any special character, just letters.

 

October 9, 2019 - 11:18pm
Response to vigog

From https://community1.pega.com/community/pega-support/question/email-channel
As email channel implicitly create email listener for the account you mention and if that listener is already present, it shows such error message.

But you mentioned that listener was not created. Can you check on that?

 

Pega
October 10, 2019 - 3:07am
Response to Shekhar_Shubham

I tried a few times deleting and recreating email account without any luck.

After your last response I created a new email account with a new name and this time everything worked fine (Verification and Save). I guess there's something corrupted in the db, creating brand new (new name) email account overcome that situation.

We can close this thread.

 

Thanks for your help.