Question

Email Body being deleted after reading

When I extract proxy to Outlook's FindEmail, in the Robotic Studio, to read the email body, it gets deleted in the mailbox. It repeats the same with any other email I read.

Please help me with what I'm missing, or doing wrong.

Thank you.

Correct Answer
February 16, 2019 - 2:41pm

Hello,

After a long struggle of not understanding what the problem was, one query from our community helped me fix the problem.

For documentation purposes;
When I connected the data (blue) line from the proxy to the properties I was using of the proxy, it was not just unproductive but in-turn counter productive. From the Outlook's FindEmail method, I extract proxy for mail, and then MUST NOT connect the data line to email's subject/body through the flow. And that's where I got my email body/subject of the mail I was referring to without being deleted after reading it.

I'm not sure if this was the solution that fixed it, but when I tried this, I no longer have deleted subject/body from the specific email that I'm reading from Outlook.

Comments

Keep up to date on this post and subscribe to comments

Pega
February 12, 2019 - 3:33am

Hi Arfath,

Can you post the screenshot of your solution/Automation? 

 

February 16, 2019 - 2:41pm

Hello,

After a long struggle of not understanding what the problem was, one query from our community helped me fix the problem.

For documentation purposes;
When I connected the data (blue) line from the proxy to the properties I was using of the proxy, it was not just unproductive but in-turn counter productive. From the Outlook's FindEmail method, I extract proxy for mail, and then MUST NOT connect the data line to email's subject/body through the flow. And that's where I got my email body/subject of the mail I was referring to without being deleted after reading it.

I'm not sure if this was the solution that fixed it, but when I tried this, I no longer have deleted subject/body from the specific email that I'm reading from Outlook.