Question

Devops - pipeline issue in DM 02.01.03

Pipeline manager is throwing error for marketing rules..

Issue replication : Create artifacts ruleset and includes marketing rules like strategy,decisiondata and try to deploy the rules via pipeline manager.

attached logs from pipeline manager.

Attempted solution : Tried to add SR class in RAP and tried. but no luck.

problem i could see with function pzRefreshPropositionCache which is getting referenced from pyDoOnSaveCommited

Please advise what could be wrong here.

***Edited by Moderator: Lochan to update platform capability tags***

Comments

Keep up to date on this post and subscribe to comments

August 5, 2019 - 4:37pm

You will have to provide more context here.  Where is the exception happening? In a QA, staging or production environment? In Dev? Which step does it fail in? 

If you are creating new ruleset and versions to be deployed, it is important that the product rule is also including the new RuleSet Versions. That could explain the exception you have included from the log

Caused by: com.pega.pegarules.pub.runtime.IndeterminateConditionalException: ** No unlocked RuleSets/Versions found that are valid for this record.  Unlock at least one RuleSet/Version that can contain records of this types.