Question

Date and Time is shown wrong for a DateTime column in Reports.

Hi All,

I've an column in report supposed to show the DateTime value.

But it is showing the difference of 5:30 hours form what is expected.

E.g: Expected value: 09/10/19 12:30 PM

Value shown: 09/10/19 07:00 AM

I've tried changing the TimeZone from America/New_York to Asia/Calcutta. But didn't worked.

Is there any alternative to resolve this..?

Comments

Keep up to date on this post and subscribe to comments

Pega
October 10, 2019 - 5:25am

HI,

Can you please perform the below steps-->

Create a new Work Object and see the Time associated to the DateTime property it would be the GMT time and the time you would enter in UI would be as per you Operator Profile TimeZone. Please have a look at difference.

Now if you run the Report Definition to show the above exposed DateTime property it should match to the TimeZone of your Operator Profile

October 25, 2019 - 12:43am
Response to setha1

Hi setha1,

Thanks for your reply,

I've already done and observed this,

  1. Time associated with the datetime property at the work object is in GMT(Asia/Cultcutta)  and
  2. Exposed DateTime Column in the Reports is showing the Operator Time Zone(America/New_York)

Now I wish to resolve that Time gap in the reports(occured due to Timezone difference).

Apart from changing the Operatro's timezone, is there any alternative..??

 

Thanks in Advance.

Pega
October 10, 2019 - 6:09am

Hi,

Calling "UpdateLocaleSettings" in one of your activity will help in resolving this issue. In this activity you can pass your required timezone as a parameter and report will use this timezone. Let me know if you need any details.

October 25, 2019 - 12:46am
Response to raavv

Hi raavv,

Thanks for your reply.

I've called "UpdateLocalSettings" in my activity with parameter(Asia/Calcutta) as my time zone in it.

But it's not working. It's throwing errors.

 

Pega
October 25, 2019 - 2:37am
Response to NagaSaiJ

Hi 

Could you please let me know what was the error you are getting.

Pega
October 11, 2019 - 11:14am

Hi,

Do check the server timezone.

In the JVM arguments you can set the required timezone and that will prevail over any other settings.

Pega
October 25, 2019 - 2:31am

Hi,

Could you try to add java step in the activity and add the below code,

com.pega.pegarules.priv.businessCalendar.CalendarUtility.removeCalendarCache(String) ;