Question

Database Table Not Working

I had set up an SQL Connection and I have run into several problems:

(1) Currently, the Database Rule seems to successfully connect with the JDBC Connection String. However, within the Database Table Rule, the Database rule is called, I leave the Reports Database blank, and I populate the table name. This has worked for me in the past. However, currently, it's simply taking too long and the connection is timing out. Upon clicking "Test Connectivity" Pega doesn't connect. This has worked before, and in the clipboard, it says that SQL connection timed out.

(2) I frequently get an SQL too many open sessions error. Is there a way to force a disconnect between Pega and an SQL database?

(3) On the increasingly rare chance that in fact the SQL database works, I have it in the form of Browsepage.pxResults(1). How do I get these fields from the clipboard into the system of record?

Thanks

Richie

Comments

Keep up to date on this post and subscribe to comments

Pega
October 21, 2019 - 10:23am

Hi Richie,

To analyse your first query, have you verified what is been traced in the logs when there is a timeout? If this was working earlier, were there any changes at your DB end ? with respect to upgrade/Firewall?