Question

Data Import using command line

Hi,

I was trying to import an admin operator from another environment using command line as I have forgotten the credentials of the same. After executing "prpcUtils.sh import" command, log shows that it has skipped overriding the record but if you see the attached property file, i have selected override option. it seems this option is valid for rule instance only. Could you please suggest? Attaching the log file as well.

***Edited by Moderator Marissa to update platform capability tags****

Correct Answer
April 15, 2019 - 4:12pm

Downloaded Pega 8.2.1 from PDN and cross checked the Media/scripts/utils/prpcUtils.properties file which has the import.insecureOperators= parameter in it, also attached the file for your reference. I suspect something issue with your utils scripts in the media, can you please download the latest media from PDN and have a look into it.

Comments

Keep up to date on this post and subscribe to comments

April 8, 2019 - 4:37pm

Hi Anand,

May be you can try to update the Administrator operator and try to export it to see if it works, because if the last modified date is same in both the environments then it will be skipped.

Regards,

Mahesh M

April 11, 2019 - 10:05am
Response to Mahesh Midthuru

I have created a new operator id and this time it got imported properly, however it says the account has been disabled. This id was working fine in environment from where I took the extract. I checked in database and for some reason pyoperatorisdeactivated in pr_operators was set as true. even after updating this vvalue to false, it still says the account is disabled. Do I have to make changes somewhere else? I have imoprted this operator id from pega which was running on version 7.3.1 and deployed it on version 8.2.1

April 10, 2019 - 2:40pm
Response to AnandP

I think from Pega 7.4 onwards, by default the operators will be disabled during import process and in Import wizard from Designer Studio you can see "Enable new operators and overwrite existing operators on import." checkbox to enable the operators.

In prpcUtils.properties i can see the below property to override the default behavior of disabling the imported operators,

# INSECURE OPERATORS?
# Allows importing operators in an insecure fashion. By default, new operators are disabled when imported,
# and existing operators are not updated. Setting this flag to true will not disable operators
# on import and allow updates of existing operators.
import.insecureOperators=

So try to set this field with true and re-import the RAP.

Hope this will resolve your issue.

April 11, 2019 - 10:04am
Response to Mahesh Midthuru

Hi,

I do not see this property in the prpcUtils.properties file which was shipped with pega 8.2.1, however I have included this manually. However operator is still disabled. I checked in the database & the field pyoperatorisdeactivated  was set back to True again. Please see the screenshot below. Making it false even doesn't solve the problem.

April 15, 2019 - 4:12pm
Response to AnandP

Downloaded Pega 8.2.1 from PDN and cross checked the Media/scripts/utils/prpcUtils.properties file which has the import.insecureOperators= parameter in it, also attached the file for your reference. I suspect something issue with your utils scripts in the media, can you please download the latest media from PDN and have a look into it.

April 24, 2019 - 3:19pm
Response to Mahesh Midthuru

It's interesting to see how come this parameter is missing for me file however the same was present for 8.1.1. However I have tried setting this parameter manually and it still didn't work. As you said, there might be something wrong with my media file. I will try to download the media again and will check if this works.