Question

DATA-ADMIN-SYSTEM-SETTINGS ! (java.lang.NullPointerException) on the monitored nodes during the AES upgrade from 717 to 72.

Hi Team,

The below mentioned exceptions has been observed in the logs of the monitored nodes while trying to implement AES upgrade from 717 to 72. (AES standalone).

Please suggest about the possible reason that can cause the issue mentioned below.

2017-08-09 22:07:36,466 [2e6c9fbe41df.event-1] [ STANDARD] [ ] ( internal.access.DatabaseImpl) ERROR - Unhandled exception on Data-Admin-System-Settings DATA-ADMIN-SYSTEM-SETTINGS ! (java.lang.NullPointerException): null
java.lang.NullPointerException
at com.pega.pegarules.exec.internal.basic.SystemSettingsImpl.processDynamicAppenders(SystemSettingsImpl.java:571)
at com.pega.pegarules.exec.internal.basic.SystemSettingsImpl.notePulseChange(SystemSettingsImpl.java:556)
at com.pega.pegarules.data.internal.access.DatabaseImpl.removeFromNodeCache_(DatabaseImpl.java:9299)
at com.pega.pegarules.data.internal.access.DatabaseImpl.processChanges(DatabaseImpl.java:9581)
at com.pega.pegarules.data.internal.access.DatabaseImpl.processChangesFromPulse(DatabaseImpl.java:9345)
at com.pega.pegarules.cluster.internal.pulseprocessor.PRPulseCacheProcessor.execute(PRPulseCacheProcessor.java:68)
at com.pega.pegarules.cluster.internal.pulseprocessor.PRPulseDispatcher.processPulseMessages(PRPulseDispatcher.java:152)
at com.pega.pegarules.cluster.internal.PRClusterHazelcastImpl$PulseListener.onMessage(PRClusterHazelcastImpl.java:939)
at com.hazelcast.topic.impl.TopicService.dispatchEvent(TopicService.java:136)
at com.hazelcast.spi.impl.EventServiceImpl$EventPacketProcessor.process(EventServiceImpl.java:549)
at com.hazelcast.spi.impl.EventServiceImpl$RemoteEventPacketProcessor.run(EventServiceImpl.java:630)
at com.hazelcast.util.executor.StripedExecutor$Worker.process(StripedExecutor.java:190)
at com.hazelcast.util.executor.StripedExecutor$Worker.run(StripedExecutor.java:174)

Regards,
Pradeep Pydi.

**Moderation Team has archived post**

This post has been archived for educational purposes. Contents and links will no longer be updated. If you have the same/similar question, please write a new post.

Comments

Keep up to date on this post and subscribe to comments

Pega
September 22, 2017 - 4:15pm

This looks like a known error that we're working on a fix for.  Reference SR-B74555.  I will track the ongoing work on a fix and respond here.

Are you seeing any issues in performance or AES processing due to this issue, or just seeing the issue in the logs?