Question

Can I use Pega Robot Studio to automatically login to PeopleSoft

So, in my project, I have a Web Application where PeopleSoft is set as StartPage. Whenever I click “Start Interrogation,” the PeopleSoft login page will pop up.

I also dragged the capture icon to UserID, Password, and Sign-In button to create controls.

Usually, when I start interrogation, my UserID will be there already. So I only need Pega to automatically enter my password and login for me. I tried to create a workflow but it’s not working.

Is it possible for Pega to remember my UserID and Password? So whenever I click Start Interrogation, it can automatically login to PeopleSoft.

Comments

Keep up to date on this post and subscribe to comments

Pega
November 14, 2019 - 8:42am

In your screenshot of the controls, it does not show you matching on your login controls. Specifically, form1 is not matching. Is that just a bad screenshot, or does it not match? If it isn't matching, you'll need to resolve that.

As for saving credentials, there are several ways. The easiest is to use the ASO Manager.

http://help.openspan.com/191/Innovations/Assisted_Sign-On_Component.htm

November 14, 2019 - 2:41pm
Response to tsasnett

How can I tell whether they are “matched” or not?

I tried to delete and re-assign all my controls. Then I found out that when I interrogated the web first time, green checks will appear besides “frmlogin”, “btnSign_In”,”txtpwd”, “txtUserID” icons. But when I click “Stop Interrogation”, and start again, these green checks will disappear.

Does that mean they are not matched? If so, how can I resolve that?

Thank you,

Pega
November 14, 2019 - 5:40pm
Response to EmmaG637

Yes, that means they are not matched. You'll need to look at the match rules for frmLogin as it must have a match rule that does not work every time the page loads. Perhaps it is using a URL match rule and the URL changes. You'll need to establish what is different between each launch to correct that.