Discussion

Can I use Deployment Manager to manage application pipelines on earlier versions of the Pega Platform?

This answer depends on which version of deployment manager you are using, and which platform versions you are targetting. This post will outline version support.

Can I use the latest version of Deployment Manager version 4.x to manage application pipelines where the target environments (Development, Quality Assurance, Staging & Production) is on Pega Platform version 7.4 ?

Yes, you can use a newer version of Deployment Manager orchestrator (version 4.x) with targetr environments which are on Pega Platform 7.4.

A few things to keep in mind when follow this configuration

  • The target environments should be have PegaDevOpsFoundation v3.4.1 in the app stack.
  • Note the limitations on the tasks that are supported for 7.4. DM 4.x series have introduced a number of new task types that are not compatible with 7.4 platform versions, however all the pipeline tasks that were supported in DM v 3.4.1 will continue to work. The specific tasks that are not supported include
  • Also note that any of the Merge related enhancements such as triggering a pipeline directly from the merge wizard, associating user stories and bugs and so on are not supported until your Dev system is also on Platform version 8.x and the PegaDevOpsFoundation is on 4.5 or greater.
  • In version 4.5, some of the repository related diagnostics will not function properly for 7.4 target environments. This will be addressed in a future release of DM.
  • The Deployment Manager 4.x orchestrator will have to be installed on the latest version of Pega Platform.
  • NOTE - This is a strongly recommended setup as with this approach you are able to take advantage of the latest and greatest features of the Deployment Manager while only being limited in a few tasks overall.

Can I use the latest version of Deployment Manager version 4.x to manage app pipelines where the target environments in Pega Platform version 7.3 or 7.3.1 ?

​No. The lowest version where Deployment Manager is backwardly compatible is Pega Platform 7.4 . There are a number of significant functional changes introduced in Pega platform 7.4 that makes it difficult to support older versions for Deployment Manager. Our recommendation is to upgrade to Pega Infinity 8.x and take advantage of the latest and complete capabilities of Deployment Manager.

This is a frequently asked question about Deployment Manager. Find more answers here.

Comments

Keep up to date on this post and subscribe to comments