Question

Can anyone help me with the changes of the web.xml for enabling api?

I am getting the attached error if im trying to hit the api URL from Pega. In the web.xml, we have defined the url-pattern as below in the WebStandard servlet mapping, but it doesn't seem to work for us.

<servlet-mapping>

<servlet-name>WebStandard</servlet-name>

<url-pattern>/api/*</url-pattern>

</servlet-mapping>

Is there something we can do to make it work? We can't use /* alone as it breaks some other functionality for us.

***Edited by Moderator Marissa to update platform capability tags****

Comments

Keep up to date on this post and subscribe to comments

December 7, 2018 - 9:59am

Hello, 

Are you referring to Resources --> Pega API ?

 

Thanks.

 

December 7, 2018 - 5:15pm

PegaAPI (assuming that PegaAPI is what you are trying to use) is enabled almost by default. Maybe this article can help you setting up:

https://community.pega.com/knowledgebase/articles/pega-api-pega-platform

December 10, 2018 - 6:46am

Hi,

I am referring to the methods under the service package 'api', which are referenced by the robot for picking up the assignments from the queue using the assignment service. As i mentioned earlier, if we are using /*, it is working fine for us but breaks some other functionality for us (ability to open static images). On the other hand, if we use /api/* , then it gives the attached error for us.