Question

Autocomplete Vertical Scroll Bar missing in Production (IE Only)

Hi Guys,

**Happening in PROD Only**

seeing weird issue with Autocomplete control where it has more than 100 records to display. When accessing the application from Chrome, its working fine and I am able to vertically scroll through the results, but when accessing from IE, dont event see any vertical scroll bar.

Correct Answer
September 23, 2019 - 1:18am

Hello,

It is an expected behaviour of Autocomplete in IE.

List based ACs are designed to perform better and load results quickly, but they will show the top 8 results. If user want to filter more results, he has to type more characters. This is the intended use of ACs.

Moreover, in a table based AC, if you are loading more than 100 results it will definitley perform slow. same behaviour can be observed in grids if it loads more than 100 results without pagination. This is not supposed to be an intended use case of Autocomplete as per design.

It is suggestable to show lesser results or change it to list based AC.

Comments

Keep up to date on this post and subscribe to comments

September 22, 2019 - 12:01am

Hi,

You can check below support article which is similar to your issue. It may help you.

https://community.pega.com/support/support-articles/vertical-scroll-bar-not-getting-displayed-auto-complete

Pega
September 22, 2019 - 1:32am

You can try to give 'Max results displayed' in the Autocomplete control a smaller number, eg. 10.

September 22, 2019 - 11:08pm

Please use developer's tools to figure out the difference in the CSS code in both the browsers.

Pega
September 23, 2019 - 12:56am

Hi,

  • Are you using a table view or list view?
  • If list, have you checked "Allow scrolling for more results"?
  • Does this happen with lists smaller than 100 records?
  • What is the behavior in UI gallery?

Thanks

Pega
September 23, 2019 - 1:18am

Hello,

It is an expected behaviour of Autocomplete in IE.

List based ACs are designed to perform better and load results quickly, but they will show the top 8 results. If user want to filter more results, he has to type more characters. This is the intended use of ACs.

Moreover, in a table based AC, if you are loading more than 100 results it will definitley perform slow. same behaviour can be observed in grids if it loads more than 100 results without pagination. This is not supposed to be an intended use case of Autocomplete as per design.

It is suggestable to show lesser results or change it to list based AC.

September 23, 2019 - 7:15pm
Response to rakss

Adding to my colleague's comment you can restrict the user to enter more number of characters to show the list (for example "Min Search Character" value can be set to 3 or 4 so that the matching list will be shown after entering atleast 3 or 4 characters). This will allow the list to be small.

September 24, 2019 - 1:21am

Thank you all for your inputs. I gone through the autocomplete design and seems it was pulling all the results without any "Max results displayed" and "Min search characters" restriction. I think I need to talk to the BAs and revert back to the user about the control's OOTB behavior.

Pega
September 28, 2019 - 5:08pm
Response to Abhinav_Chaudhary

Hi @Abhinav_Chaudhary - Can you confirm your application behavior with the OOTB autocomplete control on the UIElements. If the control is not honoring Max results and Min search options, then that is a legit problem. But, pl confirm the behavior on OOTB controls and submit an SR if you confirm there is a bug here. We can assist you further! Thank you.