Question

Attached File Name which has special characters replaced with untitled file when mail get triggers with attachments.

Hi Everyone,

When a file attached with chinese characters as file name file is getting corrupted to .dat file.

For this we had HOTFX that resolved my problem. But File name is replaced with untitled file in mail.

I tried my level best to figure it out where it is changing

1) tried in java step of pyuploadfile activity

2)tried by keeping alert in pzmultifilepath control

3)tried in pega OOTB activity sendsimpleemailwithallattachments.

4)checked in service export path in server.

5)In attachments related classe Data-WorkAttach-File,Link-Attachments of specific instance.

every where file name is exactly same which i attached i.e.,chinese characters. But in mail file name is getting replaced with untitled file.

Thanks,

Arun.

**Moderation Team has archived post**

This post has been archived for educational purposes. Contents and links will no longer be updated. If you have the same/similar question, please write a new post.

Correct Answer
September 17, 2018 - 12:49am

Yes this HOTFIX resolved both the issues File format and File Name but before commit need to scan catalogue file.

Comments

Keep up to date on this post and subscribe to comments

September 3, 2018 - 1:38am

Hi there,

pyFileUpload is the property which contains the filename. Use the option "Watch" in tracer to identify the point where the value of this property is getting changed.

Also, it might be possible that your application server doesn't support chinese characters due to which the filename is getting changed when the file gets uploaded to the server. Check with your admin team if the server has the required encoding to support the characters being used. UTF-8 encoding is capable of handling all the characters.

September 4, 2018 - 3:15am
Response to AjayRangarh

I already mentioned I debugged pyUploadFile activity and checked in server i.e., Service Export path the file name is same which we attached.

 

Thanks,

Arun.

Pega
September 4, 2018 - 3:48am

If you are running Pega 7.2.2, you need HFix-40251.

Regards

Simon

September 4, 2018 - 4:47am
Response to chans3

Hi chans3,

yes my application running pega 7.2.2 and we deployed this HTFIX but that is for file format not for file name change i think so..

 

I am attaching the HTFIX screenshot.

September 17, 2018 - 12:49am
Response to chans3

Yes this HOTFIX resolved both the issues File format and File Name but before commit need to scan catalogue file.