Question

Asynchronous Data Page not working 7.1.9

Hello, I'm trying to load Datapage Asynchronously. On tab click calling activity which will do load Datapage method at step 2 and show harness will be executed at step 16. In harness have section which contains a layout inside thus layout, section include and the context page is data page and the layout is configured as defer contents. But until unless the datapage execution completes then only im able to perform button clicks and remaining things. Thanks...!

***Updated by moderator: Lochan to tag SR details***

**Moderation Team has archived post**

This post has been archived for educational purposes. Contents and links will no longer be updated. If you have the same/similar question, please write a new post.

Group Tags

Correct Answer
December 5, 2017 - 12:51am

Swarenendu, it seems to be working fine now. Please see my closing comments on the SR

"I just discovered the problem. The section had a visibility condition dependent on the Data Page itself. So that was getting fired & causing the DP to load synchronously.

I had to tweak the section & the when conditions so that the when rule doesn’t fire before the section is referred. It seems to be working fine now."

 

Please check in the tracer if your DP is loading asynchronously or not by checking ADP. Also see the word Doc I am attaching for complete details on how to achieve non blocking UI in Pega 7

Comments

Keep up to date on this post and subscribe to comments

May 2, 2017 - 4:27pm

Are you using connect-wait somewhere in your steps? If yes, go ahead create a SR for further investigation with GCS.

Pega
May 2, 2017 - 7:34pm

Hi, 

Please check this pdn online help:

https://pdn.pega.com/sites/pdn.pega.com/files/help_v719/procomhelpmain.htm#methods/load-datapage/load-datapage.htm

Connect-Wait is used to wait for pages loaded by Load-DataPage.

The pool id parameter to Connect-Wait method is a token used to group Data Pages loaded in the background by Load-DataPage method. When this parameter is set, the Connect-Wait method will wait for all the data pages that are loaded with the same pool id.

So, in your use case, you can add step 3 as "Connect-Wait" and then the rest of steps of your activity. 

Thanks,

Susan

 

May 3, 2017 - 12:29am

Yes Step 3 is connect wait.

 

The Data Page Source activity having step 1 as java which will do Thread Sleep for 30 seconds. I have added this step to test Asynchronous Data Page Functionality.

Pega
May 5, 2017 - 8:44pm

Hi Srinivas,

Your Step 3, "Connect-Wait', has an empty WaitSeconds. 

Can you put a value there? 

Thanks,

Susan

 

May 9, 2017 - 1:19am
Response to SusanLiu

Hello Susan,

Kept seconds still not working..
My requirement is to load Data Pages Asynchronously which will avoid blocking UI.

This is what I'm trying to do.
we have 6 sections in 6 layouts (Defer Load) for each of them context page is using data page and these data pages are configured loading asynchronously using Load-Data Page.

I'm only able to perform UI actions after all of them are loaded.

Is non blocking UI concept not existing anymore in Pega 7 ?
https://pdn.pega.com/how-configure-non-blocking-ui-using-asynchronous-declare-pages

One more question is if we are loading Data Page asynchronously then if I use Connect-Wait then this process finally making the Data Page as Synchronous only right.Let me know if my assumption is wrong.

Thanks..!

Pega
May 8, 2017 - 8:46pm

Hi, 

In the tracer, if you don't see the Data Page to be loaded, please try to do a data page cleanup - do a "flush all" on your D_Test_Async data page.

Thanks,

Susan 

May 15, 2017 - 2:11am

Which version of pega are you using?we were using 7.1.7 and had same issue,raised an SR,after the hot fix installation its working.

November 8, 2017 - 4:29am

Non blocking UI not working for me either. I have opened SR-B54349 for this. It is not working consistently even for the Pega Support team & they are looking into the issue. WIll update once SR is resolved

December 5, 2017 - 12:43am
Response to NIKUBHAN

Hello,

Did you got an update on the SR to resolve the issue to create non blocking UI. We are also having the same issue in Pega 7.2.1

Thanks.

December 5, 2017 - 12:51am
Response to SwarnenduB9083

Swarenendu, it seems to be working fine now. Please see my closing comments on the SR

"I just discovered the problem. The section had a visibility condition dependent on the Data Page itself. So that was getting fired & causing the DP to load synchronously.

I had to tweak the section & the when conditions so that the when rule doesn’t fire before the section is referred. It seems to be working fine now."

 

Please check in the tracer if your DP is loading asynchronously or not by checking ADP. Also see the word Doc I am attaching for complete details on how to achieve non blocking UI in Pega 7