Question

Assign value to one of the Report Definition filter criteria at run time is not working.

Hi,

I am using OOTB filters for Report Definition. I have Filters F1 and F2, F2 filter will not be displayed to user but will be included in filter condition. When a value is selected/entered for filter F1 then the same value need to be assigned to F2 as well. I tried setting the property of F1 to F2 but it did not work.
Please advice if you have any solution for this other than using custom section.

Thanks

***Edited by Moderator Marissa to update SR Details***

Group Tags

Comments

Keep up to date on this post and subscribe to comments

Pega
September 4, 2019 - 1:41pm

Hi

What version of Pega are you on?

What is your motivation for doing this? Please help us understand the use case.

Thanks

September 5, 2019 - 1:08am

Hi,

We use PEGA 7.4 version. Attached document has the real time scenario, please have a look and advice. Hope this is a common scenario in the reporting world. Please let me know if you have any solution for this.

Note that we are converting Listview from the previous version of pega to Reportion Definition in 7.4. We have more 200 Report Definitions converted and most reports has this requirement/scenario. We planned to use only OOTB filters instead of custom filter section.

Please let me know if you have any questions.

Thanks

Pega
September 18, 2019 - 5:04pm

I believe you can do this if you check the "Display filters using custom section" on the Report Viewer tab of the report definition. This allows you to design the filter section and gives you control over what happens when a value is entered for AccountNumber.

September 27, 2019 - 12:36am

Hi, Yes I knew the Custom Section Option as I mentioned earlier, but we are currently migrating to 7.4. As part of it we are migrating all the Listviews  to Report Definition, there are more than 150 Listviews that are converted to RD. It is difficult to create Custom Section for all the RD, so we decided to use default filters. Let me know is there any option to resolve this issue other than creating Custom Section for Report Filters.

Thanks

Pega
October 3, 2019 - 2:33pm

I don't believe there is any OOTB way to do this.

How many of the 150+ list views have this issue and have distinct filter requirements? I'm guessing you could re-use some of the custom filter sections for multiple reports, which should reduce the amount of work.