Question

Application skin rule not accepting the decimal values for item spacing in grid layouts

Hi team,

Facing a issue to save the skin rule inline grid double with a decimal values.

When entering a value for item spacing as 0.5, it get converted to 5. This happens for both "px" and "em". We are using our own application skin.

We are facing a problem to save the skin rule to higher version as all defaults get the decimals converted to integer values.

Please help here, have attached a screen shot in attachments.

Comments

Keep up to date on this post and subscribe to comments

Pega
September 12, 2019 - 8:22am

Hi Vishal, 

 

When I try the same at my end, it is working for me. 

Can you let me know which version of pega you are using?( I tested in pega-8.2.1)

September 13, 2019 - 12:56am
Response to mojjs

Thanks for the reply, we are using a Pega 7.4 version on a cloud platform.

Pega
September 13, 2019 - 5:48am
Response to VishalAswale

Hi Vishal,

I have tried the same thing at my end, but it is working fine for me. Are you seeing any errors while saving as?

Can you try performing the use case with OOTB sample application. 

September 13, 2019 - 6:54am
Response to mojjs

Hi mojjs,

The OOTB sample application is working. We have a organisation skin, it is saved from the enduser71. I raised a SR for the issue, and the last update is that some validations happening when i enter the values, which converts the decimal values to integers.

So the issue seems to be with our environment skin only. And reproduced with the other skin rules.

Can please share what could be the validations and any hotfix causing this issue.

Thanks and regards

 

 

Pega
September 13, 2019 - 12:23pm

Hi Vishal

Please include the SR# in this post. Also, see if the problem is only for the specific format in question (inline grid triple) or a problem with other formats as well. We don't think a hotfix could cause this issue only in your application skin.

Thanks,