Question

Anyone managed to successfully install 8.2?

Hello,

Did anyone managed to install pega platform 8.2?

We tried both fresh installation and an upgrade. Both are failing....

Regards,

Elie

***Moderator Edit-Vidyaranjan: Updated SR details***

***Edited by Moderator: Pallavi to update platform capability tags***

Group Tags

Correct Answer
May 23, 2019 - 1:41am

Here's what solved it for US:

ROOT CAUSE

Based on the Thread Dump stack, the system is locked / blocked on Tomcat connection pool implementation.

In Tomcat, there are 2 connection pool types JDBC Connection Pool org.apache.tomcat.jdbc.pool and Apache Commons DBCP connection pool. The default Apache Commons DBCP connection pool can occationally cause Thread blocks.

 

RESOLUTION

Use the JDBC Connection Pool org.apache.tomcat.jdbc.pool by including factory="org.apache.tomcat.jdbc.pool.DataSourceFactory"  setting in Tomcat's context.xml and restart the server.

 <Resource name="jdbc/PegaRULES"                                                                                        
    auth="Container"                                                                                                     
    type="javax.sql.DataSource"
    factory="org.apache.tomcat.jdbc.pool.DataSourceFactory"                                                                                      
    driverClassName="oracle.jdbc.OracleDriver"                                                                           
    url="jdbc:oracle:thin:@host:port:my_sid"                                                                        
    username="db_user"                                                                                            
    password="db_password"                                                                                               
    maxTotal="100"                                                                                                      
    maxIdle="30"                                                                                                         
    maxWaitMillis="10000"/>   

Comments

Keep up to date on this post and subscribe to comments

April 3, 2019 - 1:13pm

Hello,

Not yet tried with the installation of 8.2 personally, but it would be better if you can able to share at which step it is failing during install/upgrade and what errors are being noticed during that step. That way we can able to help you in finding its root cause.

Regards,

Mahesh M

April 3, 2019 - 1:19pm
Response to Mahesh Midthuru

Hello Mahesh Midthuru,

The environment is not starting after the upgrade, nor after a fresh new installation.

The error message is the following:

ERROR   - Could not activate managed run [pyFTSIncrementalIndexer] during server startup
java.lang.IllegalStateException: Cannot resume run [pyFTSIncrementalIndexer] with status [Resuming]. Reason: Cannot transition run to Resuming
    at com.pega.dsm.dnode.impl.dataflow.task.ResumeRunTask$ResumeTaskResult.generateException(ResumeRunTask.java:113) ~[d-node-8.2.1-225.jar:?]
    at com.pega.dsm.dnode.impl.dataflow.task.TaskResultHandler.propagateExceptionIfExists(TaskResultHandler.java:13) ~[d-node-8.2.1-225.jar:?]
    at com.pega.dsm.dnode.impl.dataflow.service.DataFlowOperationsRunHandler$6.resume(DataFlowOperationsRunHandler.java:273) ~[d-node-8.2.1-225.jar:?]
....

Appreciate your help

Thank you

Elie

 

 

April 3, 2019 - 2:09pm
Response to erahal

Based on the above stack trace it seems to be an issue with your DNodes, where it is failing to resume one of your DNode while server start up, may be the respective SMEs should able to help you on this issue. Also you can share the complete stack trace for their analysis going forward.

April 3, 2019 - 2:19pm
Response to Mahesh Midthuru

Thank you Mahesh Midthuru,

I will let convey the above to our technical admin,

In the meantime any idea why personal edition 8.2 is not available on the website?

Thanks

Elie

April 3, 2019 - 2:53pm
Response to erahal

In the meantime any idea why personal edition 8.2 is not available on the website? - not sure why the 8.2 version is not yet available on the website.

May 22, 2019 - 5:03pm
Response to erahal

What was the final resolution of this?  I'm having the same exact problem.  I get the exception you mentioned and then pega hangs and doesn't finish loading.

May 23, 2019 - 1:43am
Response to AndyWeedman

I added the correct answer that we got from support.

If it didn;t work, as a workaround we were restarting the complete virutal machine

May 31, 2019 - 9:34am
Response to AndyWeedman

The factory thing was the fix for me too.  Hopefully they'll update the deploy guides soon.  It seems this is pretty widespread after asking around.

April 4, 2019 - 2:59am

Anyone Else tried to install 8.2? And managed to do it successfully?

May 21, 2019 - 8:25pm

I was able to install 8.2.1 successfully on Windows 10.

On Windows 7 it does not work properly. After logging on using Administrator@pega.com/install, it puts me on Dev Studio. This is as expected. However, when I try to create Admission, UIKit is missing and PegaApp cannot be chosen since Radio button is disabled. Unsure what the issue is.

I have tried on 2 different Windows 10 machines. Worked.

I have tried on 2 different Windows 7 machines. Does not work. I realize Windows 7 is seeing it's last days but it should work.

May 23, 2019 - 1:41am

Here's what solved it for US:

ROOT CAUSE

Based on the Thread Dump stack, the system is locked / blocked on Tomcat connection pool implementation.

In Tomcat, there are 2 connection pool types JDBC Connection Pool org.apache.tomcat.jdbc.pool and Apache Commons DBCP connection pool. The default Apache Commons DBCP connection pool can occationally cause Thread blocks.

 

RESOLUTION

Use the JDBC Connection Pool org.apache.tomcat.jdbc.pool by including factory="org.apache.tomcat.jdbc.pool.DataSourceFactory"  setting in Tomcat's context.xml and restart the server.

 <Resource name="jdbc/PegaRULES"                                                                                        
    auth="Container"                                                                                                     
    type="javax.sql.DataSource"
    factory="org.apache.tomcat.jdbc.pool.DataSourceFactory"                                                                                      
    driverClassName="oracle.jdbc.OracleDriver"                                                                           
    url="jdbc:oracle:thin:@host:port:my_sid"                                                                        
    username="db_user"                                                                                            
    password="db_password"                                                                                               
    maxTotal="100"                                                                                                      
    maxIdle="30"                                                                                                         
    maxWaitMillis="10000"/>   

July 2, 2019 - 12:23pm

This has worked for us as well. Thanks.

August 15, 2019 - 5:32pm

Do this solution works when I have two nodes running?