Question

Android custom mobile app showing “Application Installation failed” message after sometime of launching mobile app

We have uploaded Android Cert into Dev environment. We were able to build the app but when we download, install and then try to open the app, it shows only Pega logo and after sometime it give error – “Application Installation failed”. Did anybody encountered this type of issue any time. Please let me know if anybody knows solution for this.

Correct Answer
June 1, 2018 - 4:29pm

This issue is fixed. We got the public certificates for our app and it is working fine now.

Comments

Keep up to date on this post and subscribe to comments

May 7, 2018 - 5:54am

When mobile app is started for the first time it downloads Pega app from Pega server. The usual reason of the error you're seeing is Pega server not accessible for some reason:

- device is not connected

- Pega server is in internal network not reachable for mobile device

- url embedded in mobile app is incorrect, it can be modified by checking 'use alternative url' at a build time

June 1, 2018 - 4:29pm
Response to Mateusz Pedzierski

This issue is fixed. We got the public certificates for our app and it is working fine now.

September 2, 2018 - 9:28am

For Publishing certificate--> Need to upload apk in Google store right?

Please correct my understanding, I'm facing same issue.

November 14, 2018 - 8:35am
Response to odelum29

Not needed. You need public certificate for HTTPS, then it will works.