Question

After an error in the activity, I can’t get to the authorization screen

Hello

I created an activity in which I used the Obj-Browse method. In the Obj-Browse method, I specified the pxCommitDateTime field instead of pxCreateDateTime. In the class to which I referred this field is not. And I got an error in the tracer

Activity configuration:

Class VSK-Freight-Data-Logs is mapped to DB table. This field is not in the database table.

After I got this error and log off from the application. When I try to log in, I get the following screen

In the file below, I attach the server logs. Please help with solving this problem.

Correct Answer
November 14, 2019 - 8:32am

Hello

I reinstalled PRPC and everything works fine. Thanks for the help

Comments

Keep up to date on this post and subscribe to comments

October 25, 2019 - 9:26am

1. Does the DB table (for VSK-Freight-Data-Logs class) have a blob column?

2. Did you try to restart the server?

October 28, 2019 - 2:20am
Response to vaspoz

1) Yes.

2) Yes, I already tried to restart the server, it did not help.

October 31, 2019 - 5:04pm
Response to MaximI83

I agree with Laurence 

In logs there is no reference of that activity. May be you try below options.

It might be browser cache issue can your try clearing the cache and login in new session. If administrator id is not working then if you have any frameworks then try to login with framework modal operators and see that helps to reset admin pass word. 

October 28, 2019 - 11:51am

I'm not too sure why a failure in an Obj-Browse would cause a login failure down the line.

Is the Web-Login rule customized? If not, which version are you running on?

 

October 28, 2019 - 12:26pm

Based on the log file: 

PRRuntimeException: Section 'Web-Login' execution error. : The page or property (unspecified) is read-only, and cannot be modified

..there's as error in Web-Login section. Did you customize it?

Plus, did you try to login using the default admin creds (administrator@pega.com)?

October 31, 2019 - 8:49am
Response to vaspoz

Can you please let me know default user password. I have tried with install, administrator etc. nothing worked. 

October 31, 2019 - 9:30am
Response to Divya Miryala

if it's not "install" then someone changed it

November 14, 2019 - 8:32am

Hello

I reinstalled PRPC and everything works fine. Thanks for the help