Question

AES: Alert: Pega004: The Service Activity Max KPI value expecting is 1 sec to execute.

Hi Team, we are often getting poor performance alert for the Email Listen service activity. Even though we have declared the maximum processing time in service rule is 500 sec. How can we avoid these kind of alerts? Because the listener activity obliviously takes more than one minute to execute.

Comments

Keep up to date on this post and subscribe to comments

September 17, 2019 - 1:23am

Possible to enable debug on com.pega.pegarules.integration.engine.internal.services.email.EmailListener and send the PegaRULES log to see if we narrow down where the slowness is?

 

September 17, 2019 - 2:36am
Response to WaikeiKwok_GCS

Hi sir, the solution I am looking for is how can we customize the KPI threshold value differently where ever we know it that rule execute more time possibly.  

September 17, 2019 - 2:15pm
Response to venkat kaza

The link mentioned by @dasn1 should help,

https://community.pega.com/knowledgebase/articles/pega0011-alert-total-request-time-exceeds-limit

<env name="alerts/services/totalRequestTime/threshold" value="1000" />

The default threshold setting is 1000 milliseconds (1 second).

Pega
September 17, 2019 - 1:28am

Hi,

From the snapshot provided, I could see pega0011 alert . Could you please confirm us which alert you are observing.

Please find more details about Pega0011 and pega0004 alerts below.

https://community.pega.com/knowledgebase/articles/pega0004-alert-quantity-data-received-database-query-exceeds-limit

https://community.pega.com/knowledgebase/articles/pega0011-alert-total-request-time-exceeds-limit

Thank You,

September 17, 2019 - 2:30am
Response to dasn1

sorry, the alert we are facing is pega0011.