Question

Actions menu is missing when we run the report definition after the upgrade to Pega 8

Hi,

When we run any report definition, the Actions menu (export to excel, etc) is missing after the upgrade to Pega 8.1.3. There is no change made to the Report viewer. Please advice if there is any system settings to be changed.

Thank you.

***Edited by Moderator: Pallavi to update platform capability tags***

Correct Answer
November 9, 2019 - 5:55pm

Hi, could you review the below suggestions - 

a. Login with the default operator administrator@pega.com and the password and try if you can reproduce the issue. Or add PRPC:Administrator access group to your operator record, and then switch the application after you have logged in. Please run any OOTB report definition and see if the issue reproduces.

b. If the issue does not reproduce (my hunch is - issue might not reproduce!), then something is overriding in your application causing the Actions menu not to show. Try to use the OOTB skin rule pyEndUser to ruleout any skin related issues. 

c. If the issue does reproduce with OOTB operator / access group, then, it appears you have missed an upgrade step. You can engage us with an SR and we would be glad to investigate the issue further for you.

Thank you

Comments

Keep up to date on this post and subscribe to comments

Pega
October 23, 2019 - 2:18pm

Hi,

Confirm whether the Action menu button is missing or the Menu items from the actions button is missing.

If the Action menu items are missing then check whether "Enable actions" checkbox is enabled under "Report Viewer"and the options are selected from the list. Below is the screenshot for reference,

Select the menu items from the "Options" button.

If the Action menu button is missing kindly verify the below configurations,

Check which header section the report is using. You can identify the same by using Live UI tool.

Does "Edit report" button is visible in the report header?

By OOTB, the report uses "pyReportEditorHeader" header section. Kindly verify the same and provide screenshots to look further.

Thanks,

Geeda.

October 23, 2019 - 4:28pm

Hi

In the Reportviewer tab, the Enable actions check box is checked. It is the Action Menu button missing. When I checked the header section, it shows it displays the "ReportSectionMain" And also non of the Action item is seen. I have the attachment.

October 24, 2019 - 2:50am
Response to Nalins_99

Is the behaviour different with a brand new Report instead of the upgraded ones?

October 24, 2019 - 10:02am

Hi

Any report definition that I run have the same issue. But I am able to see the Action menu, if I open in the older version. Also it is only 2 of us in the team having this issue. Others are able to see the Actions Menu. Is there any system settings that we need to change?

Pega
October 29, 2019 - 9:02am
Response to Nalins_99

Hello,

The section used to display the actions button is the "pyReportEditorHeader". Could you perform a Revalidate of this section?
Configure->Systems->Release->Upgrade->Validate and select this section.

Also just wanted to know if the access group that your operator is included in, is different from your teammate who is able to see the button.

November 1, 2019 - 3:29pm
Response to Evita_08

Hi,

The Accessgroup is not different from my teammate. And I am not able to select the section to revalidate.

November 2, 2019 - 1:35pm
Response to Nalins_99

If accessgroup is same and if it is working others then it is cache issue. Try to open the section through live ui and do private edit of pyReportEditorHeader section check and also If your not finding pega-reporting ruleset in revalidate window then try to add that ruleset temporarily in your application and after revalidate save you can remove. 

November 6, 2019 - 10:07pm
Response to Deva_Prathapaneni

I tried to open in the Live UI, RRFiltersAndDropzone section opens. I also tried to do a private edit of the pyReportEditorHeader section and it did not work. Finally tried to fine the ruleset in valideate and as it was not available, added Pega-Reporting:08-01 to the application ruleset and saved. Later tired to find it in the Configure->Systems->Release->Upgrade->Validate and did not find it. Not sure what else to do.

Pega
November 2, 2019 - 12:06am

Hi Nalins,

Thanks for posting the query.

Could you please check the visibility condition on the actions button in the particular section which might be the reason to not show the button at run-time.

November 3, 2019 - 8:48pm

Could you please navigate to Configure > User Interface > Application Readiness > HTML5

Select UI Element tab and check if there is any update button.

Please attach the screen-shot of the same page.

 

November 6, 2019 - 9:43pm
Response to Vikash Karn

Hi

I have attached the screen shot that you requested. I expanded all the menu and did not find any rule that needed an upgrade.

Pega
November 8, 2019 - 4:23pm

It looks like menus are not upgraded. Go ahead and click on the Upgrade 'Show menu' button.

November 8, 2019 - 5:43pm
Response to mahab_GCS

Yes, clicked on the button mentioned. But no luck. 

Pega
November 9, 2019 - 5:55pm

Hi, could you review the below suggestions - 

a. Login with the default operator administrator@pega.com and the password and try if you can reproduce the issue. Or add PRPC:Administrator access group to your operator record, and then switch the application after you have logged in. Please run any OOTB report definition and see if the issue reproduces.

b. If the issue does not reproduce (my hunch is - issue might not reproduce!), then something is overriding in your application causing the Actions menu not to show. Try to use the OOTB skin rule pyEndUser to ruleout any skin related issues. 

c. If the issue does reproduce with OOTB operator / access group, then, it appears you have missed an upgrade step. You can engage us with an SR and we would be glad to investigate the issue further for you.

Thank you

November 11, 2019 - 3:03pm
Response to tanie_GCS

Hi

The option A worked. We have a Foundation layer, Framework layer and then the Application layer. In the Foundation layer the Actions menu is seen. But in the FW Layer and the Application layers, it is not. I could not find, where it got overridden.