Question

Tracer disable error , how to fix it ?

Tracer disable error , how to fix it ?

Message was edited by: Vidyaranjan Av | Included Category

**Moderation Team has archived post**

This post has been archived for educational purposes. Contents and links will no longer be updated. If you have the same/similar question, please write a new post.

Comments

Keep up to date on this post and subscribe to comments

June 8, 2016 - 9:28am

Hi,

Check if the information in the article helps you - https://pdn.pega.com/support-articles/getting-errortracer-disable .

If not, elaborate on your question so the community can guide you further.

Vidyaranjan | Community Moderator | Pegasystems Inc.

June 8, 2016 - 9:31am

It generally means way too many lines are being performed while the tracer is on.  Often this is due to long loops.  An important concept to remember is that the internal server tracer buffer is way ahead of the lines you actually see on the tracer browser screen, so if you are performing a huge number of lines, often you will see the tracer-disabled message even though not many lines have been seen on the tracer browser screen.

Try starting with a less ambitious trace.  For instance, try tracing activity entrances and exits but NOT all activity steps and when-rules.

Or, try tracing just ONE activity (which will necessarily include the activities it calls).

You could possible find it useful to trace only certain rulesets.

There is a param in prconfig you can put in (I don't remember the name) to increase the tracer buffer but I do not recommend changing that parameter, as you could run out of disk space entirely.

/Eric

Pega
June 11, 2016 - 4:18pm

Please share your observations, Thank you!