Question

Is there any hot fix in Pega 7.1.7 for "https://pdn.pega.com/support-articles/hasmessages-causes-operationfail-error"

Is there any hot fix in Pega 7.1.7 for "https://pdn.pega.com/support-articles/hasmessages-causes-operationfail-error"

@hasMessages causes OperationFail error

SUMMARY

After upgrading from Pega 7.1.6 to Pega 7.1.7 the @hasMessages function does not work as expected. Error is generated when using the function.

ERROR MESSAGES

@OperationFail() || @hasMessages(Param.WorkObjectPageName) null

STEPS TO REPRODUCE

1. Use @hasMessages in an activity. 2. Call this activity from the post action of the flow action to observe the issue.

ROOT CAUSE

The issue occurs when you remove pyWorkPage in post processing activity of flow action.

RESOLUTION

The issue is resolved in Pega 7.1.8.

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Pega
December 16, 2015 - 8:37am

Hi Rasaiya,

I dont think there is any HFIX for this . Please plan for an update to latest ML release to enjoy the advanced features of PEGA.

You can see the details in the release note here : https://pdn.pega.com/release-notes

December 16, 2015 - 8:44am

search the internal database, does not look there is any hotfix for this. Try not to remove pyWorkPage, that should avoid such error. Or update to 7.1.8 (or the latest) if possible.

December 16, 2015 - 10:32am
Response to KevinZheng_GCS

Not fair, there is should be hot fix for the known issue

December 16, 2015 - 10:43am
Response to RasaiyaNadar

Hi Rasaiya,

Pega is trying to be consistent with industry standard by releasing maintenance releases periodically (similar to IBM fixpacks), for the good of our customers. A hotfix is only going to be approved with substantial business justification (e.g., blocking major use cases in production). Each maintenance release has gone through full cycle of qa/testing/system testing whereas ad-hoc hotfixes have not. Hope this clarifies.

December 16, 2015 - 1:39pm
Response to KevinZheng_GCS

what is working in previous version should work in the new version also ,otherwise no one would prefer to use the software

December 16, 2015 - 1:51pm
Response to RasaiyaNadar

Agreed. Normally backward compatibility issues (if proven) will be approved. You can create a service request to start the process or if the impact is so small you can simply try the local solution.