Discussion

(section XYZ) does not exist for use by this recrd

(section XYZ) does not exist for use by this record(Validate). eAttempting to embed a section rule and I receive this error. What could be the cause of this?

**Moderation Team has archived post**

This post has been archived for educational purposes. Contents and links will no longer be updated. If you have the same/similar question, please write a new post.

Comments

Keep up to date on this post and subscribe to comments

November 1, 2011 - 10:00pm

Check whether the section XYZ is accessible to you through your profile.

1. Check the applies to class of section XYZ exists in inheritance path ofyour validate rule
2. Check the RUleset version of secetion XYZ is in your profile list
3. Check availability of the section XYZ is yes

October 7, 2013 - 12:05pm

Hi, I also have same error.

 

I am not just trying to include sction XYZ in a different section named ABC of same class.

 

For me all 3 checks you asked above are yes.

February 12, 2014 - 4:39pm

Hi,

for me all below things are yes : 1. Check the applies to class of section XYZ exists in inheritance path ofyour validate rule 2. Check the RUleset version of secetion XYZ is in your profile list 3. Check availability of the section XYZ is yes

 

but still getting the error

March 13, 2014 - 9:03am

Solution for my case (same error): revalidate and save the section XYZ

April 14, 2014 - 3:21am

For me :

Check the applies to class of section XYZ exists in inheritance path ofyour validate rule.

I was using section rule and trying to embed it into a harness rule which was in my work class

June 21, 2016 - 9:51am

I delete XYZ section and also its layout and add again new layout and section, then fix this issue.