Discussion

Rule not found exception

I am running the production log files..

I am seeing lot of exceptions in log files, message is

"com.pega.pegarules.pub.generator.RuleNotFoundException: Failed to find instance @baseclass.CoveredHeaderForReview of type Rule-Obj-HTML "

is it really fall under performance issue? pls let me know how to fix this issue.

**Moderation Team has archived post**

This post has been archived for educational purposes. Contents and links will no longer be updated. If you have the same/similar question, please write a new post.

Comments

Keep up to date on this post and subscribe to comments

October 21, 2010 - 4:07pm

GURRAMR2 wrote: "com.pega.pegarules.pub.generator.RuleNotFoundException: Failed to find instance @baseclass.CoveredHeaderForReview of type Rule-Obj-HTML "

This is not a performance issue per se. It generally happens when your processing stack tries to render a stream rule without a primary page. Since it has no primary page, it just looks in @baseclass. Does this have anything to do with the work you were doing over two years ago?

November 4, 2013 - 3:31pm

Hi ,

I am too getting a similar kind of error.

Failed to find instance C-B-O-Work-C-F-A.Test1 of type Rule-Obj-Activity

The Test1 activiy is under C-F-O1-Data-Cl-I

The pyWorkpage on the clipboard shows

C-B-O-Work-C1-F-A    whose directed parent is C-F-O1-Work-C1-F-A  and who directed parent is

C-F-O1-Work-C1-F

The activity is called from a click of a checkbox which is in section under class C-F-O1-Data-Cl-I   There is no Test1 activity under C-B-O-Work-C-F-A  ,

Then how come at runtime it calls C-B-O-Work-C-F-A.Test1  and throws the exception .

Do we need to save the Test1 activity in any of the of the above classes which I have mentioned.

With the above design , it works perfectely on Dev but fails on the QA region.(Would a QA server restart would help to resolve this issue ? )

Please provide any help on this .

Danny

November 4, 2013 - 3:39pm

Post the link to your question, don't repost it here.