Question

Pega url after enabling SSL/TLS on app server doesnt work  without hashed session id in url

Hi  - Can some one please help me resolve the issue which I am facing after importing SSL/TLS certificates and performing other configuration on app server.

Now I can access my pega using url : https://xyz.mycompany.com/prweb/PRServlet/beEBp4uRVTogorRwSwWqbOtn9IL2fwdI*/!STANDARD

but I can not access pega using this url(without hashed requestor id in the url) https://xyz.mycompany.com/prweb/PRServlet. When I enter this url in my browser it seems trying to connect to server but after a minutes is shows "This page can't be displayed" error in IE browser instead of pega login screen in IE11.

I need to make sure that  this url (https://xyz.mycompany.com/prweb/PRServlet) works without any session id in the url. So am I missing something in configuration?

My application details are as below:

Pega v7.1.5

Pega's native form based authentication(no custom authentication)

TLS 1.2 on weblogic app server

**Moderation Team has archived post**

This post has been archived for educational purposes. Contents and links will no longer be updated. If you have the same/similar question, please write a new post.

Comments

Keep up to date on this post and subscribe to comments

November 4, 2015 - 3:36am

Can you explain a bit more about your expectations with a URL doesn't have session id part?

November 4, 2015 - 12:50pm

Hi Chunzhi Hong - Thank you for your response! we are trying to implement SSL/TLS to access to pega. Web-logic admins have done their part and imported the certificate and done necessary changes on server side. Today we recycled server and cleaned up cache and now when we try to access pega using "https" (https://xyz.mycompany.com/prweb/PRServlet) it does not come up, for few seconds it seems trying to connect to pega and then it give give below error:

The connection has timed out

The server at xyz.mycompnay.com is taking too long to respond.

    The site could be temporarily unavailable or too busy. Try again in a few moments.    If you are unable to load any pages, check your computer's network connection.    If your computer or network is protected by a firewall or proxy, make sure that Firefox is permitted to access the Web.

This is happening only for pega application while other app hosted on same server instance are working using https url. Though pega application is working fine and is accessible using http url(http://xyz.mycompany.com/prweb/PRServlet )

November 4, 2015 - 5:06pm
Response to DPSSingh

Do you mean with the secured URL, even the log in screen doesn't appear?

November 4, 2015 - 6:34pm
Response to Chunzhi_Hong

Yes Chunzi! Now after server restart pega login screen it self is not coming when we use secure URL. Since it is kind of urgent I created a SR an hour back with all the screenshot and fiddler trace but I am yet to receive response from GCS team on this SR( SR-A12075). If you could help on this forum then I can withdraw the SR. Please suggest.

November 4, 2015 - 7:04pm
Response to DPSSingh

is your pega application deployed on a dedicated server instance?

there could be many server instances running on different ports for different applications.

Can you double check the server instance configuration to see if the ssl port is enabled as described in below link?

Administration Console Online Help

November 4, 2015 - 7:52pm
Response to DPSSingh

GCS team has better connections to SMEs and richer experiences for solving problems, so please keep contact with the GCS engineer who is handling your case. You can mention this mesh thread in your SR.

November 5, 2015 - 10:16am
Response to Chunzhi_Hong

Sure Chunzhi. I will update the SR with this thread and also I will check if we have enabled SSL listeners and ports.

November 5, 2015 - 12:04pm
Response to DPSSingh

My team will engage with Dhirendra regarding this issue under  SR-A12075.

November 3, 2016 - 12:20pm

What was the resolution?