Max file upload size using dynamic system setting

Hi All,

I want to restrict the maximum file upload size to 10 MB.

I am trying to achieve this by creating a dynamic system setting as follows:
Owning Ruleset: Pega-Engine
Setting Purpose: prconfig/initialization/maximumfileuploadsizemb/default
Value: 10

I restarted the server as well. But still the file upload limit restriction is not kicking in.

What else do I need to do?

Thanks in advance,

**Moderation Team has archived post**

This post has been archived for educational purposes. Contents and links will no longer be updated. If you have the same/similar question, please write a new post.


Keep up to date on this post and subscribe to comments

March 27, 2012 - 7:51am

HI Shrikant,

Check the setting in prconfig.xml

Open prconfig.xml in a text editor and add the following entry (in this example, 10 MB):
<env name="Initialization/MaximumFileUploadSizeMB" value="10" />


March 27, 2012 - 8:37am

Hi Pawan,

Yes. Setting the value in prconfig.xml works perfectly fine.

But I want to achieve it using Dynamic System Settings.

November 28, 2012 - 2:07am
Dynamic System Settings



November 28, 2012 - 2:07am
Dynamic System Settings



January 20, 2015 - 5:21am

anybody confirmed if this can be achieved through Dynamic System Settings or making changes to the prconfig file is the only option.

Please confirm as we are looking for the feasible solution that can be achieved without playing around the .war and undeploy-redeploy process.



May 9, 2016 - 7:34am

anybody can confirm if it is  created in default application with a predefined value?

August 10, 2016 - 9:58am

Yes. it is possible to configure maximumfileuploadsizemb via the use of DSS.  That said, if you are more interested in running a check on the file size before uploading into Pega, might want to take a look at this discussion :-