Discussion

Issue while calling an SP.

I am calling an SP from my Connect SQL rule.

All the Properties that need to be sent in the SP are present in the clipboard.

 

But the SP is not triggered. I am getting an issue which shows an error as below.

 

Error :

com.pega.pegarules.pub.database.DatabaseException: There was a problem getting a list: code: -301 SQLState: 42895 Message: DB2 SQL Error: SQLCODE=-301, SQLSTATE=42895, SQLERRMC=1, DRIVER=3.65.92

 

Caused by SQL Problems.

Problem #1, SQLState 42895, Error code -301: com.ibm.db2.jcc.am.SqlSyntaxErrorException: DB2 SQL Error: SQLCODE=-301, SQLSTATE=42895, SQLERRMC=1, DRIVER=3.65.92

 

Have any onyone came across this issue. If Yes, please provide me the steps to resolve this.

**Moderation Team has archived post**

This post has been archived for educational purposes. Contents and links will no longer be updated. If you have the same/similar question, please write a new post.

Comments

Keep up to date on this post and subscribe to comments

October 28, 2015 - 12:54am

Have u found the soluton?

October 28, 2015 - 1:09am

The issue is caused due to invalid inputs given to the SP.

Please refer to below link for more details on the error code.

http://www-304.ibm.com/support/knowledgecenter/SSEPEK_10.0.0/com.ibm.db2z10.doc.codes/src/tpc/n301.dita?lang=en

October 28, 2015 - 6:24am

In my scenario i have to call the SP which is having only Out parameters.

So for Out Parameters i have created the corresponding properties and with same data types,but still i am getting the above error.

Below is my query in the Browse of Connect SQL

Call Schemaname.SPName( .OutPutProperty1 out,OutPutProperty2 out,OutPutProperty3 out,OutPutProperty4 out)

October 28, 2015 - 8:51am

There is a syntax error.

Call Schemaname.SPName( {.OutPutProperty1 out},{.OutPutProperty2 out},{.OutPutProperty3 out},{.OutPutProperty4 out})

Refer below link for more information on Connect SQL:

https://pdn.pega.com/integration/how-to-process-a-result-set-that-is-returned-from-oracle-stored-procedures

https://pdn.pega.com/forums/oracle-database/is-it-possible-to-call-stored-procedures-in-pega-0

 

Thanks,

Rakesh

November 15, 2015 - 8:20pm

 

1. This issue might occur due to missing priveledges on the user that you are using to run the procedure in external DB

2. Also try to have double check on stored procedure which should be correct as per syntax using an external data base tool like. MySQL tool . etc.

 

 

November 16, 2015 - 1:43am

This might be data type incompatible with the requested operation also