Discussion

IAC 3.0 setup problem

Hi

I am trying to setup the IAC3.0 in PRPC5.5 intance and i face issues like i get a blank page . its just showing a single line that comes under the username and password page. When i checked without gateway its working fine and wen using gateway i get this problem. Could you please share your experience if you have gone through the same issue? And i see: com.pega.pegarules.gateway.util.PRGatewayException: PRGateway Exception: error response from PRPC

Can anybody help me on this? Plz..

**Moderation Team has archived post**

This post has been archived for educational purposes. Contents and links will no longer be updated. If you have the same/similar question, please write a new post.

Comments

Keep up to date on this post and subscribe to comments

July 6, 2009 - 11:40am

Hi GARIR

I have tried with no gateway and worked fine. This problem is showing up when i configured gateway. If you can take a look i will send my configuration in general.

I really appreciate ur help!

Pega
July 7, 2009 - 4:13am

Sure, please go ahead and paste the gadget code. Seems like it is a configuration issue. Also, please check the config settings on Gateway server and gadget script/div.

July 7, 2009 - 5:49pm

Hi GARIR

HERE IS THE FULL CONFURATION PICTURE:

My html page:

<HTML>
<HEAD>
<TITLE>html test</TITLE>
<script src="PegaInternetApplicationComposer.js" type="text/javascript"></script>
<script>
pega.web.config.gatewayURL = "http://server1:port1/prgateway/PRGateway/";
pega.web.config.appName = 'PegaRULES';
pega.web.config.systemID = 'default';
pega.web.config.thread = 'STANDARD';
pega.web.config.encrypt= false;
</script>
</HEAD>
<BODY>
<div style="margin:10px 0 0 0;">
<table cellSpacing="0" cellPadding="0" border="0" width="100%" height="100%">
<tr>
<td valign="top">
<div id="PegaGadgetDIV" PegaGadget = "PegaSubmission" PegaA = "createNewWork"
PegaA_flowName = "BasicProcess"
PegaA_className = "PegaSample-Task"
PegaA_UserIdentifier = "IACUser">
PegaA_Password ="Y25Wc1pYTT0%3D"
</div>
</td>
</tr>
</table>
</div>
</BODY>
</HTML>

Gateway web.xml :

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE web-app PUBLIC "-//Sun Microsystems, Inc.//DTD Web Application 2.2//EN" "http://java.sun.com/j2ee/dtds/web-app_2_2.dtd">
<web-app id="WebApp">
<servlet>
<servlet-name>PRPCGateway</servlet-name>
<display-name>PRPCGateway</display-name>
<description>WWW interface to PegaRULES</description>
<servlet-class>com.pega.pegarules.gateway.web.PRGatewayServlet</servlet-class>
<init-param>
<param-name>ErrorPage</param-name>
<param-value>/webwb/Error.jsp</param-value>
</init-param>
<init-param>
<param-name>LogoffPage</param-name>
<param-value>/webwb/Logoff.jsp</param-value>
</init-param>
<!--<init-param>
<param-name>SessionTimeout</param-name>
<param-value>900</param-value>
</init-param>-->
<init-param>
<param-name>SecureCookie</param-name>
<param-value>false</param-value>
</init-param>
<init-param>
<param-name>LogLevel</param-name>
<param-value>FINER</param-value>
</init-param>
<init-param>
<param-name>PRPCHosts</param-name>
<param-value>default</param-value>
</init-param>
<init-param>
<param-name>default</param-name>
<param-value>http://server2:port2/prweb;IAC;;;</param-value>
</init-param>
<!--
<init-param>
<param-name>host2</param-name>
<param-value>http://PRPCServerName2:port/PRPCContext;PRPCServlet;;;</param-value>
</init-param>
-->

<init-param>
<param-name>SendBaseURLHeader</param-name>
<param-value>true</param-value>
</init-param>
<init-param>
<param-name>BaseURL</param-name>
<param-value>http://server1:port1/prgateway/PRPCGateway</param-value>
</init-param>
<!--
<init-param>
<param-name>IWMGateway</param-name>
<param-value></param-value>
</init-param>
<init-param>
<param-name>IWMHTTPServiceURL</param-name>
<param-value>http://servername:portnumber/contextroot/PRHTTPService</param-value>
</init-param>
<init-param>
<param-name>IWMHTTPServiceUser</param-name>
<param-value></param-value>
</init-param>
<init-param>
<param-name>IWMHTTPServicePassword</param-name>
<param-value></param-value>
</init-param>
<init-param>
<param-name>IWMGetSourceSystems</param-name>
<param-value>IWMGateway/IWMGateway/getSourceSystemURLs</param-value>
</init-param>
<init-param>
<param-name>IWMSourceSystemDown</param-name>
<param-value>IWMGateway/IWMGateway/SystemDown</param-value>
</init-param>
<init-param>
<param-name>IWMSourceSystemUp</param-name>
<param-value>IWMGateway/IWMGateway/SystemUp</param-value>
</init-param>
<init-param>
<param-name>IWMDownNodeHTTPServiceUser</param-name>
<param-value> </param-value>
</init-param>
<init-param>
<param-name>IWMDownNodeHTTPServicePassword</param-name>
<param-value> </param-value>
</init-param>
<init-param>
<param-name>IWMNodeFailureLimit</param-name>
<param-value>3</param-value>
</init-param>
-->

</servlet>

<servlet-mapping>
<servlet-name>PRPCGateway</servlet-name>
<url-pattern>/PRPCGateway/*</url-pattern>
</servlet-mapping>

</web-app>

Webtesting node prconfig.xml :

<?xml version="1.0" encoding="UTF-8"?>

<pegarules>
<env name="Identification/SystemName" value="pega" />
<env name="Initialization/PersistRequestor" value="OnTimeout" />
<env name="Initialization/usenativelibrary" value="true" />
<env name="Initialization/explicitTempDir" value="/**/temp" />
<env name="initialization/displayexceptiontraceback" value="true" />

<!--<env name="Authentication/redirectguests" value="false"/>-->
<!-- ADDED TO ENABLE PRPC AS A WEBNODE-->
<env name="Initialization/ContextRewriteEnabled" value="true"/>
<env name="Initialization/nodetype" value="webtesting"/>
<env name="Initialization/urlencryption" value="false"/>
<env name="Authentication/redirectguests" value="false"/>
<env name="Initialization/gatewayurl" value="http://server1:port1/prgateway/PRPCGateway/default/"/>
<!-- END OF WEBNODE ENTRY-->

<!-- use the following entry to specify resource adapter logging level at startup,
acceptable values: SEVERE,WARN,INFO,CONFIG,FINE,FINER,FINEST -->
<env name="pradapter/logginglevel" value="INFO" />

<env name="agent/enable" value="true" />

<env name="initServices/initEmail" value="true" />
<env name="initServices/initFile" value="true" />
<env name="initServices/initJMS" value="true" />
<env name="initServices/initMQ" value="true" />

<env name="database/baseTable/name" value="pr4_base" />
<!-- use the following to write in specific storage form other than default -->
<env name="database/storageVersion" value="6"/>

<env name="database/databases/PegaRULES/dataSource" value="java:comp/env/jdbc/PegaRULES"/>

<!--
Pegasystems recommends that you use Application Server connection pooling to the database for Websphere and
Weblogic. These examples are provided if you need to use Pega Connection Pooling for Tomcat or for testing purposes.
If you are using Application server connection pooling, there is no longer a need to edit this file.

Oracle 9i (Type 2) oracle.jdbc.OracleDriver jdbc:oracle:oci:@your_tns_name
Oracle 10g (Type 4) oracle.jdbc.OracleDriver jdbc:oracle:thin:@serverName:1521:db
IBM DB/2 Type 4 com.ibm.db2.jcc.DB2Driver jdbc:db2://serverName:port/dbName
SQL Server 2005 com.microsoft.sqlserver.jdbc.SQLServerDriver jdbc:sqlserver://serverName:1433;SelectMethod=cursor;SendStringParametersAsUnicode=false;ProgramName=PR ${SystemName}@${NodeName} ${DBName} #${ConnectionID}
SQL Server 2000 com.microsoft.jdbc.sqlserver.SQLServerDriver jdbc:microsoft:sqlserver://localhost:1433;SelectMethod=cursor;SendStringParametersAsUnicode=false;ProgramName=PR ${SystemName}@${NodeName} ${DBName} #${ConnectionID}

-->

<!--
<env name="database/drivers" value="com.microsoft.jdbc.sqlserver.SQLServerDriver;oracle.jdbc.OracleDriver" />
<env name="database/databases/PegaRULES/url" value="jdbc:microsoft:sqlserver://localhost:1433;SelectMethod=cursor;SendStringParametersAsUnicode=false;ProgramName=PR ${SystemName}@${NodeName} ${DBName} #${ConnectionID}" />
<env name="database/databases/PegaRULES/userName" value="a_username" />
<env name="database/databases/PegaRULES/password" value="a_password" />
-->

</pegarules>

Pega
July 8, 2009 - 6:58am

I think you need to change the following:
1. pega.web.config.gatewayURL should be a relative path: some thing like- pega.web.config.gatewayURL = '/prgateway/PRPCGateway/';
2. You may try removing Initialization/gatewayurl in prconfig.xml

Hope this helps.

Pega
July 1, 2009 - 9:24pm

I'm not sure exactly what the problem is but can you confirm that you have the following settings set correctly?
In the Gateway web.xml:
<init-param>
<param-name>SendBaseURLHeader</param-name>
<param-value>true</param-value>
</init-param>
<init-param>
<param-name>BaseURL</param-name>
<param-value>http://servername:port/prweb/PRPCGateway</param-value>
</init-param>
In PRPC (prconfig.xml):
<env name="initialization/ContextRewriteEnabled" value="true"/>

Pega
July 2, 2009 - 9:16am

You might also check the Authentication service configured properly.
Are you getting a red line saying you have to login using internal credentials below the PRPC login page? if so, try setting the use PRPC internally stored credentials property on IACAuthentication Service.
Hope this helps.

July 2, 2009 - 9:57am

Thanks for the reply guys.BIXBS! Yes I have all those configuration set up correctly. And GARIR, I tried changing the credentials property on IACAuthentication Service but it behaves the same. I used to get that red line saying that but now i dont get that i just see the blue line appears under the userid and password page.

Pega
July 3, 2009 - 6:19am

Is the gadget definition is correct? i.e app name, action, harness name etc. Are you seeing any exception on PRPC side?
May be you can first try testing with no gateway. Please follow these links:
http://pdn.pega.com/devnet/PRPCv5/KB/25277.asp
http://pdn.pega.com/devnet/PRPCv5/KB/25182.asp

Hope this helps.

February 20, 2016 - 12:18am

Hi

I am getting same error. if you resolve this issue..can you please share the solutions that how you got resolved.

-Surya.