Discussion

Flow Action is executed but section reffered in that flow action not visible.

Can anyone tell me the reason why section reffered in a flowaction is not visible,there is no visibility condition.Checked with ruless inspector,flow action is there but still section is not visible.

 

**Moderation Team has archived post**

This post has been archived for educational purposes. Contents and links will no longer be updated. If you have the same/similar question, please write a new post.

Comments

Keep up to date on this post and subscribe to comments

November 27, 2014 - 9:21am

Just a sugession, are you including the section using another page. if yes plese check whether the page is created when you launch the flow action. If page is not there section will not display. 

November 28, 2014 - 2:17am

Ya,page is not created.

November 28, 2014 - 5:19am

Depending on the version you are using you can ensure the page is created when the flow is started by setting the value of <pagename>.pyLabel to " " in the pyDefault, or pySetFieldDefaults model or data transform rule.

I know that in Pega 7 if you use the "Configure Form" fuction in the case editor to add a page then this gets set automatically.

November 28, 2014 - 5:27am

Then make sure you create the appropriate pages before loading the flowaction. you can create it in the pre activiy and popluate any values you need or make sure you create the page before  you come to flowaction. 

November 28, 2014 - 1:25pm

Hey 1st confirm me that .... both section and flow action in the same class or different?

if your flow action in work class and section in data class ----- refer section with page name in data class. still your not able see section ,  create a page in flow action in pre activity and ue that page...now will get 100% result.

 

thanks,

Raghav

December 3, 2014 - 3:05am

Thanks Raghavendra.It's working now after creating the page in preactivity.