Discussion

Declare Index not deleting.

I have one work object with two declare indexes. One of those indexes has a pagelist "Source Page Context" the other doesn't have a "Source Page Context". Each is mapped to it's own index table and it appears that records are being inserted/updated correctly. This is good.

However, I would like to conditionally index records. This is where I run into trouble. It appears that records are being sucessfully deleted out of ONE of the index tables but not the other. I know the "indexing condition" is working properly becuase the data is updated at the right time(s).

I have theories but I can't prove them at this point. Perhaps the first declare index that gets saved managed to get "lost" during the delete but the second one can be "found"? I'm suspicious of "pxindexcount" but I can't prove it. Pxindexcount seems to be a bit of a black box.

Has anyone experienced something similar to this? Please let me know if you have any questions for me. I could probably build a work around but I would love to get to the bottom of this.

**Moderation Team has archived post**

This post has been archived for educational purposes. Contents and links will no longer be updated. If you have the same/similar question, please write a new post.

Comments

Keep up to date on this post and subscribe to comments

August 9, 2011 - 8:46am

*bump*

Anyone?

Has anyone sucessfully created two declare indexes on the same work object?

Has anyone sucessfully created two declare indexes on the same work object AND used the "indexing condition" for deletes?

August 10, 2011 - 5:37am

We had similar issue sometime back. I dont remember the exact solution though but it was fixed by setting one of the property. We were uing 5.4sp2