Discussion

Database-NonexistentTable - PRDBUTIL

Hi there,

I've been trying to install PRPC 5.5 using an Oracle 10g database which already has an install of 5.4 (seperate schemas).

I've looked into the problem and thought I'd found the solution - specifying the schema name within prconfig.xml and then running the install (KB REF - http://pdn.pega.com/DevNet/PRPCv5/KB/23183.asp).

Although the table does exist I get the following error:

"Database-NonexistentTable [schema].pr4_base PegaRULES"

I'm using a WAS 6.1 environment to install PRPC 5.5. I noticed during the install PRDBUTIL mentions:

"DB Schema Name: No Schema Name specified in Web Server for access. Schema Name for Table access detemined by DB Connect User's default in Database."

I found this unsual considering within the prconfig.xml file I've put:

'<env name="database/baseTable/schema" value="[schemaname]" />'

Any ideas welcome,
Chris

**Moderation Team has archived post**

This post has been archived for educational purposes. Contents and links will no longer be updated. If you have the same/similar question, please write a new post.

Comments

Keep up to date on this post and subscribe to comments

November 24, 2014 - 6:39pm

Hi,

 

We got the same error. Have you found any solution there?

 

Thank you,

Chatura

June 6, 2015 - 5:33am

Did you put the exact schema name in the .xml file or did you put any ID that has synonyms and grants on the objects of the schema that you want to access ?

June 6, 2015 - 10:55am

Hi,

It's weired. Once we set schema name in all upper case then it worked. :)

Thank you,
Chatura