Discussion

'caught exception java.lang.StackOverflowError' when trying to open a Scheduled Task

When I try to open a Scheduled Tasks from the list of tasks from  Pega Button -> Reporting -> Components -> Scheduled Tasks, I am getting the following error.

 

Status fail
Message caught exception java.lang.StackOverflowError
Operator ID Arul.Manimozhi@bskyb.com
Requestor ID H36FE911A61ECB0C244B137C4B89E4ADF
Timestamp Fri Mar 14 12:05:32 GMT 2014
Engine Version PegaRULES 6.2 SP2 (coreAssemblyCached_62SP2_0022)

 

Does anyone know how to increase the JVM stack? Are there any issues with doing that?

Thanks!

**Moderation Team has archived post**

This post has been archived for educational purposes. Contents and links will no longer be updated. If you have the same/similar question, please write a new post.

Comments

Keep up to date on this post and subscribe to comments

April 9, 2015 - 12:55am

Is the solution for this issue obtained? I have been facing the same for about 2 days now.

Pega
April 9, 2015 - 10:30am

Hi,

You can increase the amount memory used by the JVM by modifying the run.bat or run.conf for your application server. Normally we recommend setting the amount of memory allocated to the JVM to 2 GB on 32 bit OS and 4 GB on 64 bit OS. For more detail on how to configure this entry for your Application Server please refer to the Installation Guide for your version of PRPC, Application Server, and Database by going to Resources>Deployment Guides on the PDN.

Regards,

Henry

Pega Academy