Discussion

Can NOT change work item ID prefix by overloading Data transform rule "pyDefault".

I  am trying to customize work item ID, and overloaded Data transform rule "pyDefault" in an application named "MyApp2".

I set the ".pyWorkIDPrefix" with the value of "AA-", but when I run the application, the newly created work item id was NOT started with "AA-", but started with "M-", which is the initial character of the name of the Application itselft.

 

I create the appliation using "Application Express" wizard, there wasn't a "pyDefault" Data Transform rule there, so I created a new one.

The class structure of the application is very simple, there are only two classes: MyApp2-Work and MyApp2-Work-MyApp2. The "pyDefault" data transform rule is applied to MyApp2-Work-MyApp2.

 

Can anybody explain why this simple overloading mechanism might not work as expected?

BTW, I'm using PRPC version is 6.2 SP2.

 

**Moderation Team has archived post**

This post has been archived for educational purposes. Contents and links will no longer be updated. If you have the same/similar question, please write a new post.

Comments

Keep up to date on this post and subscribe to comments

January 13, 2014 - 8:51pm

I've tried the same thing with PRPC7, but result was the same, work item id prefix couldn't be overloaded by only defining "pyDefault" data transform rule.

January 14, 2014 - 12:34am

It seems the work item id prefix defined in the Application definition rule override that of the "pyDefault" data transform rule!

January 15, 2014 - 5:15pm

yup, that's some Pega-sleight-of-hand to be aware of (and, since you work for Pega, you can confirm this).

AddWork step 11 sets pyWorkIDPrefix to pega.getWorkIDPrefix(myStepPage.getClassName()), which comes from the application defintion. After that it calls GenerateID.

But not every activity that calls GenerateID remembers to do that. PegaCA-Work's AddNoDisplay doesn't.

 

March 3, 2014 - 3:46pm

In Pega 7, Application data instance is having an option to specify the prefix of the Work object ID and that is working for me.

 

In "Cases and Data" tab, we do have an option to specify the prefix of the Case Type.

March 5, 2014 - 12:46pm

Yes, Rajani. That option goes back to v6. PRPC moved that from the Transform (formerly Model) rule pyDefault to the Application definition. 

September 20, 2016 - 2:46am

We also faced the similar issue. But our requirement is not to fix to any single prefix. So removed the prefix from application rule which will then take the logic from pyDefault DT itself