Question

MANAGING REFERENCE DATA - Impossible to "Create asset records for IT and Facilities assets"

Hello,

After creating the Assets data type and Source, I am unable to add any records t othe Assets datatype as asked in the exercise steps.

The error I have is "The reference pyTempRecordPage.ID is not valid. Reason: Property not defined: TGB-HRApps-Data-Assets ID". (see screenshots for details).

I tried deleting and recreating the data type as defined but the result is the same.

Do you have any idea what could cause this issue ?

Regards,

Patrick

**Moderation Team has archived post**

This post has been archived for educational purposes. Contents and links will no longer be updated. If you have the same/similar question, please write a new post.

Correct Answer
November 23, 2016 - 4:31am

Hello,

For information, I successfully added my record by importing a csv file (see attached).

Adding records manually via the "Add record" still fails with the same error.

Regards,

Patrick

Comments

Keep up to date on this post and subscribe to comments

November 23, 2016 - 4:31am

Hello,

For information, I successfully added my record by importing a csv file (see attached).

Adding records manually via the "Add record" still fails with the same error.

Regards,

Patrick

Pega
November 29, 2016 - 7:04pm

Dear Patrick, this is a known issue on some nodes in the exercise system. Please import the data using a CSV file as you had done as a workaround.

 

January 16, 2017 - 9:20am

Hello, i am experiecing this issue right now, even more, i am not able to upload data using a CSV. The configuration is same as PatrickM1883 ... Is there some other workaround? Thank you.

 

 

 

 

 

Pega
January 17, 2017 - 1:41pm
Response to LukasSlamka

Dear Lukas,

 

The first line of the CSV must match the property name you used. The CSV assumes ID, AssetType and AssetName, but from the error message, it seems you have named your property referenceID, AssetType and AssetName instead.

So, modify the CSV and change the first line to ensure it matches the property name used.

Regards,

Teng Hao

February 1, 2017 - 7:27am
Response to CHUAT

Hi,

Invalid property referenceID;AssetType;AssetName tries to find property called "ID;AssetType;AssetName". If you replace semicolon with comma sing you'll be able to import assets.

Best,

September 7, 2017 - 12:40am

I got around the issue by clearing the pega session cookie and opening up a new designer studio session

December 7, 2017 - 9:51am

Hello,

I have the same problem and importing the CSV file works fine.

The question I have left is if PEGA already has a definitive solution to this problem

regards

Pega
January 27, 2018 - 3:13pm

Clearing the cookies did not fix it for me.

January 28, 2018 - 12:17am

I am completely stuck at this stage. I have tried changing all semi-colons to commas and back again. I get rows of error messages. This glitch in the system is still not fixed?

Still need a work around....