Discussion

Assignments KEY deleted (.pxAssignmentKey missing) and did not matched with work objects

Hi Every one !!

ISSUE:
I have one issue, in my production system for some interaction/service items i am getting the error - " Unable to open an instance using the given inputs : ASSIGN-WORKLIST ABC-XYZ-CSM-WORK CO-866!CAPTURECASEDETAILS"

 

Assignment Error

 

Action I made :
When I delete the entire row of the corresponding Interaction in pc_assign-worklist I am able to recreate the same in Dev Box.

References : 
When I gone through PDN I found that this is because of the .pxAssignmentkey not present for this specific Item and it was also mentioned that we can repair the assignment with the Restore this assignment Button

https://pdn.pega.com/system-operations/how-to-fix-assignments-that-are-deleted-or-do-not-match-work-objects

But in my case it was not happened please look into the screen shots and we have Restore and repair privileges that are mentioned in the pdn article.

Questions :
1. How this pxassigmentkey have missed for this Item?
2. After deleting the row if I restore the backup for the pc_assign_worklist table will it work or any keys might miss and entire workitems may get this problem (there is also BLOB column [PZPVStream] in this table) ?
3. How to solve this sort of issue ??

 

Thanks in advance !! 

Manoj Turaga

 

**Moderation Team has archived post**

This post has been archived for educational purposes. Contents and links will no longer be updated. If you have the same/similar question, please write a new post.

Comments

Keep up to date on this post and subscribe to comments

Pega
October 22, 2014 - 9:47am

Hi Manoj,

what exercises is this from?

Regards

Stavros Dimitriou
Pega Academy Support Team

Pega
October 22, 2014 - 10:12am

What exercise are you working on?

Pega
October 22, 2014 - 10:12am

What exercise are you working on?

October 22, 2014 - 10:17am

sorry this was not exercise it was an issue occured in our production system : the screen shot shows that assignment error, can you guyz help in solving this

Pega
October 22, 2014 - 10:27am

Restoring the database should fix ths issue. If I understand what you did, you deleted a row of values directly from the database. This is something that PEGA would advise you against doing. Now there is a key mismatch as a primary key is gone. If this doesn't work, you will need to contact support. This forum is supposed to be for questions regarding the CPM training material. There are other forums related to CPM outside of PEGA Academy that would be a better vehicle for a question like this.

October 24, 2014 - 6:24am

We are also getting the same error in the prod env, when a work object is opened from user's worklist. But when the user logs off and log in again,he is able to open the work item.

What could be the reason for such behaviour? Any help would be appreciated.

October 24, 2014 - 7:32am

is it so : user can able to work on the case that was previously went to Error Flow (is that you ment to say ??)

Resolution :

1. Run the FixProblemAssignments Activity and provide the handle key then the work item will be routed to the Administrator then you can move to the other's work list

2. You can also change the activity params (Param.OperatorToInform,Param.AssignmentType)AssignmentType can be (Worklist or WorkBasket) | OperatorToInform : can be the operator to whom you want to send.

3. PEGA Button -- Process & Rules -- Tools -- Work Admin -- Worklist/Workbasket Assignment Errors

go to the above path in Pega you can find the list of error work items select and press

(ClearErrorStatus) Button.

Try these resolutions I think it should work.

October 24, 2014 - 8:14am

Actually when user opens a particular work item he is getting the error, but the next time if he logs off and logs in again in the portal and tries to open the same work item he is able to open the item without any error. We are not able to reproduce the same , the issue happened in prod env.